Skip to content

Latest commit

 

History

History
48 lines (44 loc) · 1.17 KB

1925.md

File metadata and controls

48 lines (44 loc) · 1.17 KB

题目描述 输入一系列整数,将其中最大的数挑出,并将剩下的数进行排序。

输入 输入第一行包括1个整数N,1<=N<=1000,代表输入数据的个数。 接下来的一行有N个整数。
输出 可能有多组测试数据,对于每组数据,
第一行输出一个整数,代表N个整数中的最大值,并将此值从数组中去除,将剩下的数进行排序。
第二行将排序的结果输出。 如果数组中只有一个数,当第一行将其输出后,第二行请输出"-1"。
样例输入
5
5 3 2 4 1
样例输出
5
1 2 3 4

#include <iostream>
#include <algorithm>
using namespace std;
int main() {
    int n;
    while(cin>>n) {
        int s[n],i ;
        for ( i = 0; i < n; i++) {
            cin>>s[i];
        }
        if (i==1) {
            cout<<s[0]<<endl;
            cout<<-1<<endl;
        }
        else {
            sort(s, s + n);
            cout << s[n - 1] << endl;
            for (int j = 0; j < n - 1; j++) {
                cout << s[j];
                if (j < n - 2) cout << ' ';
            }
            cout << endl;
        }
    }
    return 0;
}